Installation

Aus Wiki-500-Euro-RTM
Wechseln zu: Navigation, Suche

Die Entwicklung der Software ist bereits erfolgt, so dass diese nur noch auf dem Computer installiert werden muss. Unten ist eine Anleitung gegeben, wie die Software auf dem Computer installiert werden kann. Abhängig davon für welchen Computer man sich entscheidet, ist die obere für den STM32F407 und die untere Anleitung für den ESP32 im M5-Stack. Eine Bedienungsanleitung für die Software findet sich unter dem Punkt Bedienung des STMs

Aufbau mit dem STM32F407

Installation des Hex-Files auf dem Microe-Board

Prinzipiell ist die Software für diesen Aufbau vollständig entwickelt und muss nur noch auf dem STM32 installiert werden. Alle erforderlichen Parameter für den Scan können dann, sobald die Software läuft, direkt auf dem Computer eingestellt werden (s. Übersicht über die Applikation).

Zur Installation der Firmware auf dem Mikromedia Board ist wie folgt vorzugehen:

  • Board mit PC verbinden (USB Anschluss direkt auf dem mikromedia Plus Board, NICHT auf Shield)
  • mikroC Pro for ARM Demoversion installieren. Unter Tools -> USB HID Bootloader öffnen (nebenstehendes Bild)
  • Reset-Taste auf dem mikromedia Plus Board drücken, dann innerhalb von 5 Sekunden „Connect“
  • Das Hex-File auswählen und mit „Begin uploading“ die Übertragung starten.

Das Hex-File findet man zu download dann HIER

Aufbau mit dem ESP32

Auch für den ESP32 ist die Software grundsätzlich vollständig und muss nur noch auf dem ESP32 installiert werden. Die Software für den M5Stack ist in der bekannten Arduino-Umgebung geschrieben. Dadurch lässt sich leicht ein Blick auf den Quellcode werfen und Veränderungen können leicht vorgenommen werden. Dies ist jedoch für den Erfolg des Tunnelmikroskop nicht entscheidend und gilt eher als Spielraum für besonderes Interesse. Um den Vorgang zu vereinfachen, wird auf eine portable Version der Entwicklungsumgebung gesetzt. Diese hat den Vorteil, dass sie ohne Installation von Arduino auskommt und beinhaltet bereits alle benötigten Libraries und das eigentliche Programm. Einzig der Treiber zum Ansprechen des M5Stack muss auf dem PC installiert werden
Die erforderlichen Parameter für den Scan lassen sich direkt am Computer oder bequem über einen Web-Server am Handy einstellen (s. Übersicht über die Applikation).

Zur Installation der Software ist wie folgt vorzugehen:

In der zur Verfügung gestellten zip ist das Programm „arduino.exe“ enthalten. Über Öffnen dieser Datei wird die Entwicklungsumgebung gestartet. Unter „Datei -> Sketchbook“ lässt sich das Programm des RTM auswählen.

  • Der M5Stack wird im Menü „Werkzeuge -> Board“ als „M5Stack-Core-ESP32“ aktiviert. Sobald der Controller angeschlossen ist, wird unter Port ein COM-Port angezeigt, diesen wählen. Sollte kein Port vorhanden sein, liegt es an einem Treiberproblem, alternativ einem nicht angeschlossenen M5Stack.